#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)\s|Фізичне виховання|Військова підготовка|(.+№\d+|Центр Енергоефективн|БП.|ЦР.\d|ЦР\d|ПМ|ПМа|Гурт\d|Гурт.\d|ОЗ 3|\d.*?(?=\s)|)(?:\s|)(\W+?\s\W+?\s\W+?\s)(?:\s(?=\()|(?:\..?|.)*?|)(?:\s|)(?:(?:.*?[а-я. ]*)|.*?(?=[А-Я\(]))((Збірна група|Потік|)(.*(?<=-\d|\.\d|\d\,|\-\d\d|\d\d\+|\.\.\.|\(підгр\. \d\)).*?(?<=\s)|)|)(.*(?=\())(.*)"
Local $sString = "" & @CRLF & _
"443 Жуковська Наталія Анатоліївна ст. викладач Потік КН-11інт, КН-31, ПМ-41, ІПЗ-31 Теорія систем, системний аналіз та теорія прийняття рішень (Л)" & @CRLF & _
"141а Герус Володимир Андрійович (підгр. 2) Архітектура обчислювальних систем та системне програмування (Лаб)" & @CRLF & _
"680 Христюк Андрій Олексійович ст. викладач Історія науки і техніки в галузі (Л)" & @CRLF & _
"680 Христюк Андрій Олексійович викладач Історія науки і техніки в галузі (Л)" & @CRLF & _
"628 Цибульський Валерій Іванович доцент Історія та культура України (ПрС)" & @CRLF & _
"679 Степанюк Антон А Збірна група КІ-41, ПМ-41, Безпека життєдіяльності та цивільний захист (ПрС)" & @CRLF & _
"245 Мальчик Мар`яна Василівна зав. кафедрою Збірна група ЗГБ-70 Рекламний креатив (Л) " & @CRLF & _
"629 Шикун Алла Володимирівна асистент Збірна група ЗГБ-9 Англійська мова (курс з використанням матеріалу по темі `Міжнародна ек (ПрС) " & @CRLF & _
"248 Волошин Володимир Степанович доцент Збірна група ЗГБ-5 Адміністрування інформації в 1С:Підприємство (Л)" & @CRLF & _
"141а Прищепа Оксана Володимирівна ст. викладач (підгр. 2) Випадкові процеси та їх моделювання (Лаб)" & @CRLF & _
"812 Корбутяк Віктор Іванович доцент Потік АКІТ-11, ЕЕЕ-11, ІПЗ-11, ІСТ-11, КІ-11, КН-11, ... Я-студент (Л)" & @CRLF & _
"Клепач Микола Іванович доцент Окремі питання теорії автоматичного управління (ПрС)" & @CRLF & _
"Клепач Микола-Богдан Іванович доцент Окремі питання теорії автоматичного управління (ПрС)" & @CRLF & _
"437 Яковлева-Гаврилюк Ольга Миколаївна доцент Техніко-еокномічне обгрунтування ГЕО (ПрС)" & @CRLF & _
"802 Купчик Лариса Євгенівна доцент Збірна група ЗГБ-74 Розмовний курс сучасної англійської мови (А2/В1) (ПрС)" & @CRLF & _
"354 Осецька Наталія Феліксівна ст. викладач Збірна група ЗГБ-27 Ділова документація англійською мовою (ПрС)" & @CRLF & _
"278 Малевич Леся Дмитрівна зав. кафедрою Збірна група ЗГБ-34 Ефективна комунікація в професійній діяльності (Л)" & @CRLF & _
"Спорткомплекс - фітнес ( дівчата) ," & @CRLF & _
" 646 Байцар-Артеменко Оксана Вікторівна ст. викладач (підгр. 1) Регіональна архітектура (ПрС)" & @CRLF & _
"" & @CRLF & _
" Ромашко Олена Василівна асистент ЕП(BTEA)-1 Регіональна архітектура (ПрС)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")