package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[a-zA-Z0-9_.]+[@]{1}[a-z0-9]+[\.][a-z]+$)`)
var str = `iletisim@ahmetbarut.net
deneme@mail.
ahmetbarut588@gmail.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}