$re = '/^(.*[\\\\\/])/';
$str = '/webshop/product/Brabantia-6L-Sort--Go-Waste-Bin-Grey/342586011';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);