$re = '/(\[.*?\].*?\[\/.*?\])/';
$str = 'This in text [bar](rec)[/bar] [foo](big)[/foo] color';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);