re = /^[a].*[a]$|^[e].*[e]$|^[i].*[i]$|^[o].*[o]$|^[u].*[u]$/
str = 'start of string'
# Print the match result
str.match(re) do |match|
puts match.to_s
end