using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z]+((\ [A-Z\.]+)|(\ *\([A-Z]+\)))*";
string input = @"ABCDE (ABCDE) AAAAA ASWSWS.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}