#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^((AT)(U\d{8})|(BE)(0\d{9})|(BG)(\d{9,10})|(CY)(\d{8}[LX])|(CZ)(\d{8,10})|(DE)(\d{9})|(DK)(\d{8})|(EE)(\d{9})|(EL|GR)(\d{9})|(ES)([\dA-Z]\d{7}[\dA-Z])|(FI)(\d{8})|(FR)([\dA-Z]{2}\d{9})|(HU)(\d{8})|(IE)(\d{7}[A-Z]{2})|(IT)(\d{11})|(LT)(\d{9}|\d{12})|(LU)(\d{8})|(LV)(\d{11})|(MT)(\d{8})|(NL)(\d{9}(B\d{2}|BO2))|(PL)(\d{10})|(PT)(\d{9})|(RO)(\d{2,10})|(SE)(\d{12})|(SI)(\d{8})|(SK)(\d{10}))$"
Local $sString = "ATU12345678" & @CRLF & _
"BE0123456789" & @CRLF & _
"BG123456789" & @CRLF & _
"BG1234567890" & @CRLF & _
"CY12345678X" & @CRLF & _
"CY12345678L" & @CRLF & _
"CZ12345678" & @CRLF & _
"CZ123456789" & @CRLF & _
"CZ1234567890" & @CRLF & _
"DE123456789" & @CRLF & _
"DK12345678" & @CRLF & _
"EE123456789" & @CRLF & _
"EL123456789" & @CRLF & _
"GR123456789" & @CRLF & _
"ESX12345678" & @CRLF & _
"ES12345678X" & @CRLF & _
"ESX1234567X" & @CRLF & _
"FI12345678" & @CRLF & _
"FR12345678901" & @CRLF & _
"FRX1234567890" & @CRLF & _
"FR1X123456789" & @CRLF & _
"FRXX123456789" & @CRLF & _
"HU12345678" & @CRLF & _
"IE1234567WA" & @CRLF & _
"IE1234567FA" & @CRLF & _
"IT12345678901" & @CRLF & _
"LT123456789" & @CRLF & _
"LT123456789012" & @CRLF & _
"LU12345678" & @CRLF & _
"LV12345678901" & @CRLF & _
"MT12345678" & @CRLF & _
"NL123456789B01" & @CRLF & _
"NL123456789BO2" & @CRLF & _
"PL1234567890" & @CRLF & _
"PT123456789" & @CRLF & _
"RO1234567890" & @CRLF & _
"SE123456789012" & @CRLF & _
"SK1234567890"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")