re = /^\w+([-+.']\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*$/m
str = 'vule0310@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end