#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w+-gradient\(.*?\)\)|\w+-gradient\(.*?\)"
Local $sString = "Only Match CSS gradients ignoring everything else." & @CRLF & _
"" & @CRLF & _
"EXAMPLES" & @CRLF & _
"" & @CRLF & _
"2 and 3+ colors any type (4 matches): \w+-gradient\(.*?\)\)|\w+-gradient\(.*?\)" & @CRLF & _
"3+ colors linear (1 match): linear-gradient\(.*?\)\)" & @CRLF & _
"2 colors linear (4 matches): linear-gradient\(.*?\)" & @CRLF & _
"2 colors any type (4 matches): \w+-gradient\(.*?\)" & @CRLF & _
"" & @CRLF & _
"---" & @CRLF & _
"" & @CRLF & _
"linear-gradient(148deg, #c2fd88 24%, #89fc80 100%); //green" & @CRLF & _
"linear-gradient(148deg, #fff 24%, #000 100%); //gray" & @CRLF & _
"`background-image: linear-gradient(to right, rgb(236, 72, 153), rgb(239, 68, 68), rgb(234, 179, 8));`" & @CRLF & _
"$highlight-rainbow: conic-gradient(from 195.94deg at 50% 50%, #FF1B71 -28.98deg, #E0201A 0.41deg, #EE3F16 27.93deg, #FF6128 54.73deg, #FDA206 88.8deg, #FFED00 117.65deg, #DFF051 145.77deg, #17AB70 175.77deg, #1A8F9C 207.65deg, #005AFF 239.36deg, #5C4ECE 274.87deg, #582C86 304.33deg, #FF1B71 331.02deg, #E0201A 360.41deg);" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")