import Foundation
let pattern = #"^([0-9]{4})(\s*|\/|[-]|[.])([0-1][0-9])(\s*|\/|[-]|[.])([0-9]{2})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
January 14, 2018
2018/07/18
20180718
2018.07.18
2018-08-18
181007
20181202
201107
921109
13 กันยายน 2535
1ธันวาคม2561
1ธันวา2561
5 กันยา 61
1กันยา2501
1 September 2018
15October18
1/9/2018
10/3/2018
12/12/2018
4 กันยา 2018
12-12-18
12-9-2018
12Sep 2018
15มีนาคม 2018
15.Sep.2018
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)