# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Opuściwszy"
test_str = ("Opuściwszy wieżę charakterników, powróciłem do domu. Sprawy organizacyjne związane z wydobyciem smoka z morskich otchłani zmierzały ku końcowi. Pozostała kwestia ponownego dogadania się z Gildią Kupiecką, a następnie zawarcia umowy z nimi oraz rzemieślnikami. Sprawy się klarowały, dobrze.\n\n"
"Miałem teraz odrobinę wolnego czasu. Postanowiłem wykorzystać tę chwilę na rozpoczęcie studiów potężnej księgi, w której spisano wiedzę na temat odnotowanych kultów w krainach ludzi. Cóż, zapewne mógłbym wykorzystać czas na odpoczynek, zajmując się czynnościami mało angażującymi, jednakże wolałem sobie posiedzieć przy zakazanej wiedzy i dowiedzieć się czegoś nowego.\n\n"
"Powolnym krokiem wszedłem po schodach, przekroczyłem próg mojej komnaty, usiadłem przy biurku wraz z księgą. Na początku zamierzałem zapoznać się z porządkiem treści. Po zakończeniu oględzin, zacząłem szukać jakiekolwiek informacji o ruinach świątyni w Myrwen, którą prawdopodobnie zbudowano ku czci Czerwonej Istoty. ")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.