import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"Status\":(\"?)(?<cstatus>.*?)(\"?),.*?\"ProblemFlag\":(\"?)(?<probflag>.*?)(\"?),.*?\"IncreasePending\":(\"?)(?<increasePend>.*?)(\"?),.*?\"SafePay\":(\"?)(?<safepay>.*?)(\"?),.*?\"PastDue\":(\"?)(?<pastdue>.*?)(\"?),.*?\"LastPmtAmt\":(\"?)(?<lastpayamt>.*?)(\"?),.*?\"NextPmtAmt\":(\"?)(?<nextpayamt>.*?)(\"?),.*?\"LastPayDate\":(\"?)(?<lastpaydate>.*?)(\"?),.*?\"NextDebitDate\":(\"?)(?<nextdbtdate>.*?)(\"?),.*?\"AddendumDate\":(\"?)(?<addendmdate>.*?)(\"?)(,?)\\}";
final String string = "{\"Status\":\"AP\",\"ProblemFlag\":\"0\",\"IncreasePending\":\"1\",\"SafePay\":\"1\",\"PastDue\":\"0\",\"LastPmtAmt\":\"0.00\",\"NextPmtAmt\":\"453.00\",\"LastPayDate\":\"\",\"NextDebitDate\":\"2021-02-28 00:00:00\",\"AddendumDate\":\"2021-02-15 00:00:00\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}