$re = '/^(?:.?|(..+?)\1+)$/m';
$str = '1
22
333
4444
55555
666666
7777777
88888888
999999999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);