const regex = /^LIN[\s\S]*(?=^UNS)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^LIN[\\s\\S]*(?=^UNS)', 'gm')
const str = `UNB+UNOC:3+O0013001550GDID0000Z6H:14+80585:14+200218:1455+8'
UNH+1+ORDERS:D:96B:UN'
BGM+120+4016026958'
DTM+4:20200218:102'
NAD+BY+437750'
NAD+SU+0000080585'
NAD+OB+0000080585'
NAD+DP+4000::9++Cronus Company:Cronus GmbH & Co. KG+Musterstrasse 3+Kirchdorf++12345+DE'
CUX+2:EUR'
TOD+6++DAP'
LIN+00010++079790040080030:SA'
PIA+1+079790040080030:SA'
IMD+F++:::DIN 7979 D Stahl blank | 8x30 Zylin'
QTY+12:10,000:PCE'
PRI+AAA:23,56:::100:PCE'
SCC+1'
QTY+1:10,000'
DTM+2:20200223:102'
LIN+00020++079790040080040:SA'
PIA+1+079790040080040:SA'
IMD+F++:::DIN 7979 D Stahl blank | 8x40 Zylin'
QTY+12:10,000:PCE'
PRI+AAA:24,58:::100:PCE'
SCC+1'
QTY+1:10,000'
DTM+2:20200223:102'
LIN+00030++009128009060016:SA'
PIA+1+009128009060016:SA'
IMD+F++:::DIN 912 Stahl 8.8 blank | M6x16 Zyl'
QTY+12:100,000:PCE'
PRI+AAA:2,36:::100:PCE'
SCC+1'
QTY+1:100,000'
DTM+2:20200223:102'
UNS+S'
UNT+35+1'
UNZ+1+8'
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}