using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([01]?[0-9]?[0-9]|2[0-4][0-9]|25[0-5])$";
string input = @"<--! select 0 or 000..255 sequences -->
0
00
000
001
002
004
010
011
021
100
101
110
115
120
125
127
135
139
141
201
222
230
245
247
250
254 sgnlfsf
2340
345
255
853
999";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}