package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)(\,\d+)?(\s)?m[2²]`)
var str = `appartement de 4 pièces, 2 chambres, 71,52 m²
appartement de 2 pièces, 1 chambre, 55m²`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}