using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(Depense|Recette)_Aller_\d*_*(FEDER|RR974|POCT)_\d{2}_\d{4}_\d{1,2}_\d+C\w*.xml$";
string substitution = @"";
string input = @"Depense_Aller_4689.xml : flux PJ seul, bordereau déjà envoyé, à ne pas signer
Depense_Aller_4659_661C.xml : flux complet, à signer DAF
Depense_Aller_FEDER_01_2017_1_19C.xml
Depense_Aller_FEDER_01_2017_1_19C_Auto.xml
Depense_Aller_7864_FEDER_01_2017_2_19C_Auto.xml
Depense_Aller_4344_SMPRR_01_2017_2_34C_Auto.xml
Depense_Aller_4344_RR974_01_2017_6_566C_Auto.xml
Depense_Aller_4038_RR974_01_2017_473C_Auto.xml
Depense_Aller_3469_RR974_01_2017_271C_Auto.xml : flux complet paye, à signer RH
Depense_Aller_4271_FEDER_01_2016_5A_Auto.xml : flux en annulation, à ne pas signer
Depense_Aller_2649_RR974_01_2017_5C_Auto.xml : flux indemnités élus Région, à signer par ?
Depense_Aller_3222_RR974_01_2017_216C_Auto.xml : flux indemnités élus CESER, à signer par ?
Depense_Aller_3222_RR974_01_2017_219C_Auto.xml : flux indemnités élus CCEE, à signer par ?
Appgfi\wwwGFTEST\astre\astromate\pes\recette :
Recette_Aller_4271_RR974_01_2017_6C_Auto.xml : flux recette, à signer DAF
Recette_Aller_4271_RR974_01_2016_21A_Auto.xml : flux recette en annulation, à ne pas signer
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}