#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\b(\w+)(\s+\1)+\b"
Local $sString = "Goodbye bye bye world world world" & @CRLF & _
"Sam went went to to to his business" & @CRLF & _
"Reya is is the the best player in eye eye game" & @CRLF & _
"in inthe" & @CRLF & _
"Hello hello Ab aB"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")