$re = '/primary_position:\""(.*?)\""/';
$str = 'primary_position:"1B"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);