$re = '/^(?=.*\d)(?=.*[A-Z])(?=.*[a-z])\S{8,16}$/';
$str = 'Nelson123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);