$re = '/^0(\.[0-9]+)?$|^[1-9][0-9]*(\.[0-9]+)?$/m';
$str = '0
1
01
01.1
1.1
11.1234
5123
1351523.123
0.1234
0.0
0.000
0.00001
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);