import Foundation
let pattern = #"^[+-]?\d*?\.\d+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
.01444
10.454
4.0O0
-1.00
+4.54
SomeRandomStuffand
1.0df0
10.0cv
1.aada
4+1.00254
0.5.0
+9>>10
9.7
1>>3
-2.4
-9<<9
+10.7
+2<<5
5.5
4<<8
-8.5
-7>>9
+9.50
1.h
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)