$re = '@(?<![\S\{])(http|ftp)?(s)?(://)?(([a-zA-Z])([-\w]+\.)+([^\s\.]+[^\s]*)+[^,.\s])([^\}\s]+)(?![\S\}])@';
$str = '{https://local.oqea.com}
https://local.oqea.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);