$re = '/^".*?"/m';
$str = '"C:\\Windows\\system32\\NOTEPAD.EXE" C:\\!\\inal11404 -дла оощ ыф цумщлзкщл3з мц ацул MNNMMMqpl v23 953 53262v32 - копия (2) - копия.log';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;