package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([^0-9\s_.]+)+[a-zA-Z]*((\s?)*[a-zA-Z](\s?)*)*$`)
var str = `ddfdsfsdfsfsf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}