package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\w+\W+){0,5}(?:\w+)$`)
var str = `textto
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}