$re = '/(\w+) \1/m';
$str = '匹配相同的连续出现的单词
the little cat is in the hat hat, we like it.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);