$re = '/(?<=https://)(.*)(?=:8080)/s';
$str = 'https://192.168.0.1:8080';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);