const regex = /([\w\d]{1,})(\s{0,}-\s{0,})([\w\d]{1,})(\s{1,}|(\s{0,}-\s{0,}))([\w\d]{1,})/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w\\d]{1,})(\\s{0,}-\\s{0,})([\\w\\d]{1,})(\\s{1,}|(\\s{0,}-\\s{0,}))([\\w\\d]{1,})', 'gi')
const str = `NORMAND SKIMMER DSB-WHSPLT-0212R
NORMAND SKIMMER DSB-WHSPLT 0212
NORMAND SKIMMER DSB-WHSTPLT 0212
NORMAND SKIMMER DSB - WHSPLT 0212
NORMAND SKIMMER DSB - WHSPLT - 0212
NORMAND SKIMMER 0212
NORMAND SKIMMER 0212R
NORMAND SKIMMER
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}