const regex = /(?:\.?\/?.+\/)?(?:app(?:[0-9A-F]+)?|(?:jquery|angular|three)(?:\-?\d[\-\.]\d[\-\.]\d)?)(?:\.min)?\.js$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\.?\\\/?.+\\\/)?(?:app(?:[0-9A-F]+)?|(?:jquery|angular|three)(?:\\-?\\d[\\-\\.]\\d[\\-\\.]\\d)?)(?:\\.min)?\\.js$', 'gim')
const str = `jquery.min.js
app.min.js
app.js
app4eefa86.min.js
jquery-3.2.1.js
jquery-3-2-1.min.js
/js/app.min.js
./scripts/jquery.js
/cgi-bin/angular.min.js
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}