$re = '/<\?(?!php|=|xml)?\D*?>/';
$str = '<?php endif ?>
<? endif ?>
<?= $test?>dasd
asdasdwda546awd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);