import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div\\sid=\\\"olpProductDetails[\\s\\S]*?<h1[\\s\\S]*?<div[\\s\\S]*?<span[\\s\\S]*?>[\\s\\S]*?\\s*<\\/span>\\s*<\\/div>\\s*([\\s\\S]*?)[\\s]+<\\/h1>";
final String string = "<div id=\"olpProductDetails\" class=\"a-fixed-left-grid-col a-col-right\" style=\"padding-left:0%;float:left;\">\n\n"
+ " <h1 class=\"a-size-large a-spacing-none\" role=\"main\"> <div class=\"a-section a-spacing-none olpSubHeadingSection\"> <span class=\"a-size-base a-color-secondary\"> </span> </div> Keds Women's Chillax Washed Laceless Slip-On Sneaker, Taupe, 8 M US\n"
+ " </h1>\n"
+ " <div id=\"olpProductByline\" class=\"a-section a-spacing-mini\">\n"
+ " \n\n\n\n\n\n"
+ "by Keds\n\n"
+ " </div>\n\n"
+ " <div class=\"a-section a-spacing-small\">\n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}