const regex = /^([\W\w])([^\s]){8,16}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\W\\w])([^\\s]){8,16}$', '')
const str = `Asimpl3p@ssword`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}