re = /[a-z][a-z0-9_\.]{5,32}@[a-z0-9]{2,}(\.[a-z0-9]{2,4}){1,2}/m
str = 'this maybe a email khoapham.ptithcm@yahoo.com or not ahihi@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end