re = /!\[(.*?)\]\(((?!http)\/?[^\s]+\.(png|jpg))\)/m
str = '




.png)
/
(?:!\\[(.*?)\\]\\((.*?)\\))
/
gm
!\\[.*\\]\\((?!http)[^\\)]+\\)
(?:!\\[(.*?)\\]\\((?!http)[^\\)]\\))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end