// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)\[rm_single_product_alt*.*?]").unwrap();
let string = "[vc_row][vc_column][vc_column_text el_class=\"dropcaps\"]Final de semana chegando e você está planejando dar uma fugidinha e viajar? Tirar uma folga de dois ou três dias longe de casa é ótimo, mas isso significa também organizar uma mala de final de semana. Ou seja, pequena, compacta e com apenas itens básicos. Afinal, a ideia é relaxar, e não perder o pouco tempo que se tem pensando no outfit.
E antes que você embarque na próxima viagem, confira nossas dicas para escolher as peças certas e montar uma bagagem prática, mas super funcional: [/vc_column_text][vc_empty_space][vc_column_text]
Atenção ao destino
[/vc_column_text][vc_column_text]
Foto: Camila Coelho/Reprodução Pinterest
[/vc_column_text][vc_empty_space][rm_single_product_alt rm_products_alt=\"879,1227,422,881,1070\"][vc_empty_space][/vc_column][/vc_row][vc_row][vc_column][vc_column_text]A primeira coisa que você deve fazer antes de preparar sua mala de final de semana é pensar no destino. Isso porque cada lugar exige uma bagagem diferente. Se você for para a praia, por exemplo, biquínis e roupas leves são indispensáveis. Agora se a ideia for passar uns dias em algum lugar no interior, tênis e um casaquinho devem estar na mala.
Por isso, a primeira dica é planejar todo o seu final de semana. Suas escolhas de roupa vão depender muito da programação. E não esqueça também de dar uma olhadinha na previsão do tempo. É sempre bom se antecipar. [/vc_column_text][vc_empty_space][vc_column_text]
Prefira o básico
[/vc_column_text][vc_column_text]
Foto: Reprodução Pinterest
[/vc_column_text][vc_empty_space][rm_single_product_alt rm_products_alt=\"776,839,807,881,1076\"][vc_empty_space][/vc_column][/vc_row][vc_row][vc_column][vc_column_text]A melhor forma de nunca errar é optar pelo básico. Dê preferência às cores neutras e fáceis de combinar. Ou monte roupas que combinem entre si e permitam que você crie diferentes looks. Nessa lista estão peças como calça, camisa branca, t-shirts e shorts. Evite estampas e selecione tecidos que não amassem facilmente.
Agora no verão também dá para colocar na mala alguns vestidos leves, que podem tanto ser usados durante o dia quanto à noite, caso role algum programa mais especial. Caso ocorra uma esfriadinha, tenha um casaco sempre a mão. Escolha um modelo coringa, que possa ser usado com todas as peças, além de ser leve para ocupar menos espaço possível.[/vc_column_text][vc_empty_space][vc_column_text]
Foto: Reprodução Pinterest
[/vc_column_text][vc_empty_space][rm_single_product_alt rm_products_alt=\"537,1196,870,946,1072\"][vc_empty_space][/vc_column][/vc_row][vc_row][vc_column][vc_column_text]Nos pés, a regra é a mesma. Carregue, no máximo, dois ou três pares: um para o dia a dia, que seja confortável, um para sair à noite, um pouco mais arrumadinho, e, se achar necessário, um extra também confortável. Nossa dica é sempre ter um par de tênis, super versáteis e o must have do momento![/vc_column_text][vc_empty_space][vc_column_text]
Lembre-se dos acessórios
[/vc_column_text][vc_column_text]
Foto: Reprodução Pinterest
[/vc_column_text][vc_empty_space][rm_single_product_alt rm_products_alt=\"781,1055,418,875,884\"][vc_empty_space][/vc_column][/vc_row][vc_row][vc_column][vc_column_text]Básico, mas não sem graça. Para dar uma up aos seus looks, conte com a ajuda dos acessórios. Além de dar um toque final à produção, eles ajudam a ampliar suas opções. Brincos, lenços, colares, pulseiras e cintos não ocupam tanto espaço na mala e ajudam a dar um toque fashion.[/vc_column_text][vc_empty_space][vc_column_text]
O que mais levar?
[/vc_column_text][vc_empty_space][/vc_column][/vc_row][vc_row][vc_column][vc_column_text]Além das roupas, calçados e acessórios, também é importante guardar espaço na mala para a sua nécessaire com seus itens de higiene, e itens básicos como pijama e chinelos. Depois, é só aproveitar sua viagem com a tranquilidade de estar pronta para qualquer situação.
Boa viagem![/vc_column_text][vc_empty_space][/vc_column][/vc_row]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}