// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\(.*\))( .*:)(\N*)($)").unwrap();
let string = "( 4m 7s ) Technician: Hello, my name is Technician. I will be assisting you today. How can I help you?
( 5m 45s ) User: Hello. I accidentally deleted a file and when I retrieved it. Some of the info was not the same. It's a huge estimate and I fear I may have lost it. We work with Ca Fair Plan and then sent back the estimate for me to make revisions.
( 5m 55s ) User: Hope that makes sense.
( 6m 37s ) Technician: Hi User,
You can also see if there are any other saved versions of the project, in the \"Restore previous version\" section here;
There's a document in our Answer Center I'd like you to look at that goes over this issue. Click the link below to view it. As always, let me know if you run into any trouble or have any questions, and I'll be happy to help!
https://veriskpropertyestimatingsolutions.my.site.com/s/article/1729
( 9m 15s ) User: That did not help
( 10m 26s ) Technician: Okay. If you do not see any other versions you would need to make any necessary edits to the existing file you have.
( 15m 25s ) User: Understood. I am a little confused because I have several estimates that are considered different versions. They were saved with different endings based on the revisions. I so see a estimate that is labeled SHIVRANI_NOCLN_DEP and this is the right estimate based on my clients notes about revisions he wants. But I thought when a vendor sends us back an estimate to modify the name of the estimate changes as far as an esx. Is there a way you could tell me the name of estimate that my client sent to me recently?
( 17m 57s ) Technician: I can see all the Shivrani related projects in your instance, but we don't have a way to identity whcih would have been sent by your client. There are 5 in the Carrier profile, and 3 in the Contractor profile.
( 18m 46s ) Technician: You are the \"owner\" of 3 of the Carrier projects. They all have the same total, $735,556.53
( 19m 4s ) Technician: 4_SHIVRANI_CLN_DEP(3
4_SHIVRANI_CLN_DEP(2
4_SHIVRANI_CLN_DEP(1
( 20m 26s ) User: Yes, I was looking for the one called SHIVRANI_NOCLN_DEP but with the depreciation. Some how I deleted the depreciation
( 20m 56s ) User: Line Item Total 596,101.18
California Lumber Assessment Fee 128.12
Subtotal 596,229.30
Overhead 59,623.29
Profit 59,623.29
Material Sales Tax 12,078.69
Replacement Cost Value $727,554.57
Less Depreciation (22,599.55)
Actual Cash Value $704,955.02
Less Deductible (5,000.00)
Net Claim $699,955.02
Total Recoverable Depreciation 22,599.55
Net Claim if Depreciation is Recovered $722,554.57
( 21m 0s ) Technician: That one does exist, yes. It's in the projects list. Only the one copy though. You'd need to re-apply the depreciation if you do not see any other versions of the file when using the \"Restore previous version\" button.
( 21m 21s ) User: could the vendor re-send an esx?
( 21m 29s ) User: another esx
( 22m 3s ) Technician: Maybe, you would want to ask them. If they sent you the original ESX, they could send another one.
( 26m 19s ) User: Okay. I have another questions for you. I see the email my office sent to CFP advising them the report was uploaded to Xact. We also sent the esx (the one I need) via email. It is the right amount and labeled 4_SHIVRANI_CLN_DEP it is at $727,554.57 and has the correct depreciation.
( 26m 56s ) User: Can I work of this? Maybe delete the other three version in Xact and then re-upload?
( 27m 29s ) Technician: That is certainly an option, yes. You can remove any other duplicates you don't need and if you have that ESX on hand, you can re-upload that to Xactimate.
( 37m 20s ) Technician: It’s been a few minutes since I last heard from you. I want to make sure we’re still connected and I didn’t miss your message. If you would like me to continue to stand by, just let me know!
( 37m 25s ) Technician: I’d like to check in one more time before I consider this session ended. If you are ready to end this session, please close the chat window. For the sake of time constraints and quality service, I will consider our chat session as being completed if you have not begun typing within 30 seconds.
( 38m 11s ) Technician: I checked in a few times and did not receive a response or an indication that you were still with us, and due to time constraints, our chat session ended.
Don't worry though, if you're still requiring assistance, please be sure to come right back in on a new chat and we'll make sure we pick up where we left off. Here's the reference number for this chat so you won't need to explain what has already been done to the next technician: 230804-201509
";
let substitution = "$1\\t$2\\t$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}