package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(text|border|btn-)\S+`)
var str = `btn-outline text-primary border-primary`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}