$re = '/rmi:\/\/[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}/m';
$str = '{"jmx.serviceUrl": "service:jmx:rmi:///jndi/rmi://172.123.523.1:1099/obj"}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);