const regex = /^[^<>]*((<\/?(w|phr|evHL)[^<>]*>)*([^<>]*))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^<>]*((<\\\/?(w|phr|evHL)[^<>]*>)*([^<>]*))*$', 'gm')
const str = `toto<phr start="1583554989500" end="1583554992040" confidence="0.22"><w s="1583554989500" d="60" c="0.22">Hey</w> <w s="1583554990920" d="390" c="0.18">mama</w> <w s="1583554991770" d="270" c="0.27"><evHL>poll</evHL></w> </phr>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}