re = /^(?!aem-Grid.*)/m
str = 'categoryteaser
image
aem-GridColumn
aem-GridColumn--default--12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end