package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).{2,}@.*\..{2,}`)
var str = `Email2312@gmail.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}