# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<mesini>\d{2})(?P<diaini>\d{2})(?P<horaini>\d{2})(?P<minini>\d{2})\s(?P<duracaosegundo>\d{5})\s\d{4}\s(\w|\s)\s{6}\s\s(?<rota>(\d{4})|\s{4})\s{6,18}(?<numerob>\d{4})\s(?<ramal>\d{4,8})\s{20,24}(?P<senha>(\d{6}|\s{6}))\s{8}\d{2}\s(?<tronco>(\d{5}|\s{5}))(?<nodetrunk>\d{4})\n"
test_str = ("06191520 00102 0000 J 4776 6512 00 4776\n"
" \n"
"06191522 00118 0000 4770 6512 00 024017001\n"
" \n"
"06191535 00037 0000 I 6512 98311871 00 6512\n"
"06191532 00000 0000 B 6512 98311871 00 \n"
" \n"
"06191529 00141 0000 M 0 2470 999308509 6512 00 002002003\n"
" \n"
"06191555 01854 0000 M 0 2470 33485083 6512 00 002002003\n"
" \n"
"06191655 00151 0000 M 0 2470 01128983434 6512 00 002002003\n"
"06191656 00011 0000 M 0 2470 01128983434 6512 00 002002009\n"
"06191658 00130 0000 T 0 2470 01128983434 4776 00 002002009\n"
"06191701 00137 0000 M 0 2470 01128983434 6512 00 002002009\n"
"06191701 00000 0000 0 2470 01128983434 4776 00 002002009\n"
" \n"
"06191632 00034 0000 J 4776 6512 00 4776\n"
"06191632 00034 0000 J 4776 6512 00 4776\n"
"06191634 00203 0000 T 0 2470 999308509 4776 00 002002001\n"
" \n"
"06191630 00001 0000 J 6361 6512 00 6361\n"
"06191630 00001 0000 J 6361 6512 00 6361\n"
" \n"
"06191644 00009 0000 M 0 2470 33283828 6512 00 002002007\n"
"06191645 00136 0000 T 0 2470 33283828 4776 00 002002007\n"
" \n"
"06191632 00001 0000 M 0 2470 999308509 6512 00 002002001\n"
"06191634 00203 0000 T 0 2470 999308509 4776 00 002002001\n"
" \n"
"06191656 00011 0000 M 0 2470 01128983434 6512 00 002002009\n"
"06191658 00130 0000 T 0 2470 01128983434 4776 00 002002009\n"
" \n"
"06191644 00009 0000 M 0 2470 33283828 6512 00 002002007\n"
"06191645 00136 0000 T 0 2470 33283828 4776 00 002002007\n"
" \n"
"06191632 00001 0000 M 0 2470 999308509 6512 00 002002001\n"
"06191634 00203 0000 T 0 2470 999308509 4776 00 002002001\n"
"06191652 00106 0000 M 0 2470 999308509 6512 00 002002003\n"
"06191652 00000 0000 0 2470 999308509 6512 00 002002003\n"
" \n"
"06191656 00011 0000 M 0 2470 01128983434 6512 00 002002009\n"
"06191658 00130 0000 T 0 2470 01128983434 4776 00 002002009\n"
"06191701 00137 0000 M 0 2470 01128983434 6512 00 002002009\n"
"06191701 00000 0000 0 2470 01128983434 4776 00 002002009\n"
" \n"
"06220921 00130 0000 M 0 2470 012997319079 6512 00 002002002\n"
" \n"
"06220922 00004 0000 M 0 2470 012997319079 6512 00 002002005\n"
"06220924 00157 0000 T 0 2470 012997319079 4776 00 002002005\n"
" \n"
"06220926 00144 0000 M 0 2470 012997319079 6512 00 002002006\n"
"06220926 00009 0000 0 2470 012997319079 4776 00 002002006\n"
" \n"
"06220935 00347 0000 M 0 2470 33485083 6512 578129 00 002002001\n"
" \n"
"06220938 00211 0000 M 0 2470 999308509 6512 578129 00 002002002\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.