re = /name\s?[a-z]{0,2}\s([A-Z]{1}[a-z]+)/m
str = 'This is a spotted Lipitor Rumpelstiltskin named Alphred. He can\'t wait for the Turkey. 10/10 would pet really well https://t.co/6GUGO7azNX
Sorry for the lack of posts today. I came home from school and had to spend quality time with my puppo. Her name is Zoey and she\'s 13/10 https://t.co/BArWupFAn0
Ladies and gentlemen... I found Pipsy. He may have changed his name to Pablo, but he never changed his love for the sea. Pupgraded to 14/10 https://t.co/lVU5GyNFen
HI. MY. NAME. IS. BOOMER. AND. I. WANT. TO. SAY. IT\'S. H*CKIN. RIDICULOUS. THAT. DOGS. CAN\'T VOTE. ABSOLUTE. CODSWALLUP. THANK. YOU. 13/10 https://t.co/SqKJPwbQ2g
Name a more iconic quartet... I\'ll wait. 13/10 for all https://t.co/kCLgD8687T
RT @dog_rates: This a Norwegian Pewterschmidt named Tickles. Ears for days. 12/10 I care deeply for Tickles https://t.co/0aDF62KVP7
When bae calls your name from across the room. 12/10 (vid by @christinemcc98) https://t.co/xolcXA6gxe
We normally don\'t rate bears but this one seems nice. Her name is Thea. Appears rather fluffy. 10/10 good bear https://t.co/fZc7MixeeT
This pup\'s name is Sabertooth (parents must be cool). Ears for days. Jumps unannounced. 9/10 would pet diligently https://t.co/iazoiNUviP
I would do radical things in the name of Dog God. I\'d believe every word in that book. 10/10 https://t.co/9ZuGAmLZDR'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end