$re = '/(<img(?!.*?alt=([\'"]).*?\2)[^>]*)(>)/m';
$str = '<html>
<body>
<img src="tos.jpg">
<img src="hfgfg.jpg" alt="texter alternatif">
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);