import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(#|$).*$";
final String string = "# Configuration section config.\n"
+ "# How LVM configuration settings are handled.\n"
+ "config {\n\n"
+ " # Configuration option config/checks.\n"
+ " # If enabled, any LVM configuration mismatch is reported.\n"
+ " # This implies checking that the configuration key is understood by\n"
+ " # LVM and that the value of the key is the proper type. If disabled,\n"
+ " # any configuration mismatch is ignored and the default value is used\n"
+ " # without any warning (a message about the configuration key not being\n"
+ " # found is issued in verbose mode only).\n"
+ " checks = 1\n\n"
+ " # Configuration option config/abort_on_errors.\n"
+ " # Abort the LVM process if a configuration mismatch is found.\n"
+ " abort_on_errors = 0\n\n"
+ " # Configuration option config/profile_dir.\n"
+ " # Directory where LVM looks for configuration profiles.\n"
+ " profile_dir = \"/etc/lvm/profile\"\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}