// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([\w-\.+]+)@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.)|(([\w-]+\.)+))([a-zA-Z]{2,4}|[0-9]{1,3})(\]?)$").unwrap();
let string = "Invalid:
mkyong
mkyong123@.com
mkyong()*@gmail.com
mkyong@%*.com
mkyong..2002@gmail.com
mkyong.@gmail.com
mkyong@mkyong@gmail.com
mkyong@gmail.com.1a
Valid:
mkyong@yahoo.com
mkyong-100@yahoo.com
mkyong.100@yahoo.com
mkyong111@mkyong.com
mkyong-100@mkyong.net
mkyong.100@mkyong.com.au
mkyong@1.com
mkyong@gmail.com.com
mkyong-100@yahoo-test.com
a.a@ac.cc.cc
mkyong@fdg
.dgfsdfg@dgf.dfg
mkyong+123@df.com
firstname+lastname@domain.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}