$re = '/(\d*(?:d\d+)+)|(\d+)|([+-])|([*\/])/m';
$str = '2d20 * 3 + 4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);