import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(Тема: )(.*)\\n(Дата )(\\d*.\\d*.\\d*)(.*)\\n(Время )(.*)\\n(Имя клиента )(.*)\\n(Фамилия клиента )(.*)\\n(Дата рождения )(.*)\\n(Номер загран паспорта )(.*)\\n(Дата окончания загран паспорта )(.*)\\n(Гражданство )(.*)\\n(Телефон )(.*)\\n(E-mail )(.*)\\n(Количество заявителей )(.*)\\n(Инфо )(.*)\\n(Ссылка)\\n(.*)\\n(.*)";
final String string = "Тема: Запись на прием\n"
+ "Дата 28.03.2020 17:30 - 28.03.2020 18:00\n"
+ "Время 17:30 - 18:00\n"
+ "Имя клиента Vovka\n"
+ "Фамилия клиента Simi\n"
+ "Дата рождения 283983\n"
+ "Номер загран паспорта 9839283\n"
+ "Дата окончания загран паспорта 28492849284\n"
+ "Гражданство Hjccbz\n"
+ "Телефон 9248924898\n"
+ "E-mail mail@mail.ru\n"
+ "Количество заявителей 1\n"
+ "Инфо 237582hg8yfrvgdr\n"
+ "Ссылка\n"
+ "https://france-visa-official.ru/wp-admin/admin.php?page=wpbc&view_mode=vm_listing&tab=actions&wh_booking_id=15\n";
final String subst = "\\2,\\4,\\7,\\9,\\11,\\13,\\15,\\17,\\19,\\21,\\23,\\25,\\27,\\29";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}