import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Za-z]+)(\\s*)([0,1]*[0-9])(,*\\s*)([0-9]{2,4})$";
final String string = "January 15, 2018\n\n"
+ "January 15,2018\n\n"
+ "January15, 2018\n\n"
+ "January15,2018\n\n"
+ "January 15 2018\n\n"
+ "Feb 15, 2018";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}